Sie sind nicht angemeldet.

Zypressen Hügel

Junior Schreiberling

  • »Zypressen Hügel« ist der Autor dieses Themas

Beiträge: 244

Registrierungsdatum: 22.12.2001

1

12.02.2002, 20:54

auch Linux, aber was anderes...

also, ich bin stolzer besitzer zweier betriebssysteme. xp und SuSE LINUX 7.2 (kernel 2.4.irgendwas). hat alles toll hingehauen, läuft parallel mit LILO.

leider hatte ich vor einer woche den allerersten kontakt in meinem leben zu linux (jaja, schande über mich), bin also nicht eben fit in linux.

ich habe drei probleme:

- mein brenner wird zwar als "CDRECORDER" erkannt, kann aber nicht angesprochen werden (erstmal unwichtig)
- in der console steht nach dem booten immer "module c not found" (ich weiss nicht, wie wichtig das ist)
- mein internes SmartLink 56k Modem (COM3) wird absolut nicht erkannt. yast findet auch nix. ich habe rpm-packages runtergeladen für dieses modem, aber die installation bricht immer mit "bad exit status -1" ab (wichtiges problem!!)

gibt es einen crack unter euch, der mir helfen kann?
Man kann auch ohne Spass Alkohol haben 8)

MAX

Senior Schreiberling

  • »MAX« ist männlich

Beiträge: 822

Registrierungsdatum: 11.12.2001

Wohnort: Hannover

2

12.02.2002, 21:53

Modem!!!

Ich kann dir nur was zu deinem Modemproblem sagen. Ich habe auch in uinternes Modem (aber nicht mehr lange) und das Problem habe ich unter Linux auch früher gehabt und habe jetzt und werde auch wahrscheinlich in Zukunft haben. Es ist leider so, dass interne Modems quasi speziell für Windows gemacht sind (ich weiß, es stimmt zwar nicht ganz, aber man kann es so sehen). Es ist so, dass solche Modems Software gesteuert sind. Ich weiß nicht ganz, wie das funktioniert, aber Eins steht fest: Interne Modems gehen unter Linux grundsätzlich nicht. Also das kannst du schon vergessen. Sorry, aber es ist so!
mfg
MAX

MAX

Senior Schreiberling

  • »MAX« ist männlich

Beiträge: 822

Registrierungsdatum: 11.12.2001

Wohnort: Hannover

3

12.02.2002, 22:03

Ach!!!

Ja noch Eins!!! Ich habe bei mir zu Zeit auch xp und SuSE am laufen. Was mich interessieren würde. Wie hast du und in welcher Reihenfolge und auf welchen Partitionen deiner Festplatte(n) xp und Linux installiert???
Ich verwalte die zwei Betriebssysteme mit BootitNG. Das ist halt so ein Bootmanager. Weiß ich nicht, ob du es kennst. Es ist ziemlich gut, falls man Partitionen ändern, verschieben oder verändern möchte oder man will noch ein Betriebssystem draufpacken. Es ist nämlich so, dass SuSE Linux immer in die erste Primärpartition installieren muss. (Ich bin da nicht so ganz auf dem neuesten Stand, vielleicht bei heutiger Distribution ist es anders) Das Problem ist folgendes, falls du in irgendeiner Weise Linux Partition verschieben möchtest, dann geht dein LILO nicht mehr und du kannst Linux nicht starten (schon ausprobiert?). Ich würde ganz gerne da deine Erfahrungen damit hören!!!
mfg
MAX

Zypressen Hügel

Junior Schreiberling

  • »Zypressen Hügel« ist der Autor dieses Themas

Beiträge: 244

Registrierungsdatum: 22.12.2001

4

12.02.2002, 23:01

nee, partitionen rumgeschoben habe ich noch nicht, wie gesagt, linux ist seit einer woche drauf und ich bin froh, dass es läuft.
ich habe als erste festplatte eine 30gb-platte mit 4,2GB partition ganz am anfang für win XP (reicht völlig aus), danach eine 18GB partition ext2 für linux und den rest für windows-programme (ca 8 GB). die zweite platte mit nochmal 30GB für alles andere.
ich habe partition magic 7.0 (vorgänger laufen unter xp nicht :( ) dafür benutzt. war supercomfortabel, hat gleich auf wunsch den 18GB-teil auf linux-ext2 formatiert.
wie gesagt, läuft mit LILO einwandfrei und solche spässe wie nachträglich partitionen verschieben habe ich noch nicht ausprobiert. allerdings habe ich nachträglich (nachdem linux schon drauf war) mit partition magic noch mal die xp-partition von ursprünglich 3,2 GB (war etwas knapp) auf 4,2 GB erweitert und den platz dafür von der linux-partition genommen. war mit partition magic auch kein problem, xp und linux laufen immer noch. partition magic kann ich nur empfehlen. man muss halt nur drauf achten, dass die erste partition deutlich unterhalb der ersten 1024 zylinder (8GB) bleibt, so dass die linux-partition noch "reinreicht".
im übrigen muss nicht linux auf der ersten primär-partition sein (distribution 7.2 jedenfalls nicht), sondern xp. xp liess bei mir gar keine andere möglichkeit zu. wieso ging das denn bei dir?

und warum in gottes namen kann ich unter linux kein verdammtes internes modem betreiben??? X( ?( X(
Man kann auch ohne Spass Alkohol haben 8)

  • »Joachim« ist männlich

Beiträge: 2 863

Registrierungsdatum: 11.12.2001

Wohnort: Hämelerwald

Beruf: Wissenschaftlicher Mitarbeiter (Forschungszentrum L3S, TU Braunschweig)

5

12.02.2002, 23:18

Zitat

Original von Zypressen Hügel
und warum in gottes namen kann ich unter linux kein verdammtes internes modem betreiben??? X( ?( X(
Prinzipiell geht das schon, es gibt sogar entsprechende Treiber für manche Karten (die Dinger Modem zu nennen ist eigentlich Betrug, da sie ja [im Gegensatz zu Modems im ursprünglichen Wortsinn] passiv sind). Nähere Informationen zu dieser Thematik findest du hier:
http://www.linmodems.org/
The purpose of computing is insight, not numbers.
Richard Hamming, 1962

MAX

Senior Schreiberling

  • »MAX« ist männlich

Beiträge: 822

Registrierungsdatum: 11.12.2001

Wohnort: Hannover

6

13.02.2002, 00:40

Ja hast du Recht!!!

Es ist leider war, dass xp unbedingt in der ersten Primärpartition standardmäßig installiert sein soll. Man kann es wie gesagt umgehen, indem man bekannte Bootmanager einsetzt. Man kann mit diesen Utilities Windoof vorgaukeln, dass er sich im MBR0 befindet. Da gibt es solche Funktionen dafür. Näheres gibt es unter: http://www.tecchannel.de/software/485/
Jetzt fällt mir auf, dass ich Linux und Unix (bestimmte Versionen) verwechselt habe. Man hat solche Probleme halt mit Unix, nicht jedoch mit Linux. Aber es ist auch egal.
Partition Magic 7.0 setzte ich auch ein. Das ist überhaupt das beste Tool, um Partitionen zu verwalten. Echt super.
Tja zum Modem: Ich weiß so nicht genau, warum interne Modems unter Linux nicht laufen. Wie gesagt, das Treibermodell ist hier wohl anders, als es in Linux ist. Also man kanns vergessen und sich lieber ein externes Modem besoregn. Du kannst auf der HP von SuSE auch überprüfen wie weit deine Hardware kompatibel ist.
Ok so weit so gut und viel Spaß mit Linux!!!
mfg
MAX

migu

free rider

  • »migu« ist männlich

Beiträge: 2 643

Registrierungsdatum: 11.12.2001

Wohnort: Hannover

Beruf: Developer

7

13.02.2002, 19:45

Brennen kann man unter SuSE per default nur als root.
Kannst du aber aedern, indem du die Rechte der Detaien /dev/sg* aenderst
tar: Anlegen eines leeren Archivs wird feige verweigert.

migu

free rider

  • »migu« ist männlich

Beiträge: 2 643

Registrierungsdatum: 11.12.2001

Wohnort: Hannover

Beruf: Developer

8

15.02.2002, 17:35

Zitat

Original von Zypressen Hügel
- in der console steht nach dem booten immer "module c not found" (ich weiss nicht, wie wichtig das ist)


1) Sag mal mehr, z.B. welches Modul das ist
2) Idee: Vielleicht ist in der /etc/conf.modules was inkomplett?
3) mehr weiß ich grad nicht
tar: Anlegen eines leeren Archivs wird feige verweigert.

migu

free rider

  • »migu« ist männlich

Beiträge: 2 643

Registrierungsdatum: 11.12.2001

Wohnort: Hannover

Beruf: Developer

9

15.02.2002, 17:44

ich muss mich korrigieren

cdrecord kann nur von root ausgeführt werden.
Sollen auch andere Benutzer es benutzen können, so muss
es setuid-root gesetz werden, z.B. mit folgendem Befehl:

chmod 4755 /usr/bin/cdrecord


Nun soll das aber vielleicht nicht jeder können.
Also ändert man die Rechte wie folgt:
(es sollte eine Gruppe cdrom geben, wenn nicht: anlegen)


chmod o= /usr/bin/cdrecord
chown root.cdrom /usr/bin/cdrecord


Nun musst du nur noch die Benutzer, die brennen können sollen,
zur Gruppe cdrom hinzufügen und dann läuft's.

hzh

migu
tar: Anlegen eines leeren Archivs wird feige verweigert.