Sie sind nicht angemeldet.

Benjamin

Segelnder Alter Hase

  • »Benjamin« ist männlich
  • »Benjamin« ist der Autor dieses Themas

Beiträge: 3 827

Registrierungsdatum: 01.10.2002

Wohnort: Region Hannover

Beruf: Alumni

1

13.08.2004, 08:21

Apache TomCat Caching Problem

Im Zuge meines Praktikums muss ich hier gerade an einem Java Servlet stricken. Da ich zur Entwicklung nicht an eine Produktivumgebung komme, musste ich mir selber einen Apache Tomcat besorgen um das Servlet zu testen. Das ging bisher auch schön und gut mit der Tomcat 4.
Da in der späteren Produktivumgebung jedoch die Tomcat 5 laufen wird, wollte ich nun einmal auf diese umsteigen und stoße dort auf ein Problem. Das Servlet läuft schön und gut, doch irgendwie scheint ich eine Server-Option nicht zu finden oder es gibt ein serverseitiges Caching-Problem.
Sobald ich dem Server eine neue Version des Servlets übergebe, scheint ihn das leider garnicht zu interessieren. Erst bei einem Server(Dienst) Restart (übrigens leider Windows) nimmt er das neue Servlet und präsentiert mir solange das alte.
Ist hier zufällig ein Tomcat (5) Nutzer anwesend, der dazu einen Tipp hat? ?(
Es gibt nur eine bessere Sache als auf dem Wasser zu sein: Noch mehr auf dem Wasser sein.

PhilRM

Gründer

  • »PhilRM« ist männlich

Beiträge: 867

Registrierungsdatum: 09.12.2001

Wohnort: Hannover

Beruf: äh... :)

2

13.08.2004, 19:17

Ich hatte das "Problem" damals schon bei Tomcat 4. Du musst das automatic class reloading aktivieren, sodass der Server auf neue .class-Files überprüft und diese lädt. Das ist standardmäßig eigentlich ausgeschaltet, da genau das im Produktivbetrieb ja eigentlich nicht passieren sollte (und das System zudem langsamer macht).

In TC 4 war das eine Option, die man pro Webanwendung einschalten konnte.
"Sie haben also einen, äh, einen Master of Bachelor?" (Human Resources, T-Systems, Cebit)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »PhilRM« (13.08.2004, 19:18)


Benjamin

Segelnder Alter Hase

  • »Benjamin« ist männlich
  • »Benjamin« ist der Autor dieses Themas

Beiträge: 3 827

Registrierungsdatum: 01.10.2002

Wohnort: Region Hannover

Beruf: Alumni

3

18.08.2004, 15:54

Danke.

Nachdem livedeploy="true" und autodeploy="true" mir nix gebracht hatten, hat mich dein Tip auf die richtige Option gebracht.

Quellcode

1
2
<Context path="/meinProjekt" 
            reloadable="TRUE" .........
Es gibt nur eine bessere Sache als auf dem Wasser zu sein: Noch mehr auf dem Wasser sein.