You are not logged in.

migu

free rider

  • "migu" is male
  • "migu" started this thread

Posts: 2,643

Date of registration: Dec 11th 2001

Occupation: Developer

1

Monday, November 27th 2006, 5:23pm

UHWLAN: Problem mit DNS

Umgebung:
  • IBM Thinkpad mit Intel Pro Wireless (IPW) 2100.
  • Linux (Ubuntu 6.10)
  • vpnc

Wie ich im UHWLAN online gehe:
  1. per DHCP Adresse holen
  2. vpnc starten
    [/list=1]
    Das funktioniert schon seit Jahren problemlos. Seit einigen Wochen (oder Monaten?) besteht aber folgendes Problem:
    Nach einiger Zeit (meist circa 4000-5000 Sekunden) wird der DHCP-Client aktiv und holt sich vom DHCP-Server eine (evtl.) neue Adresse (DHCP renewal). Dabei wird auch der DNS-Server neu gesetzt. In /etc/resolv.conf steht dann statt 130.75.1.{32,40} der Nameserver 192.168.11.250. Dieser liefert zu jeder Anfrage die gleiche Adresse (192.168.11.250), unter welcher eine Hinweis-Seite des RRZN liegt; dort steht, ich sei nicht per VPN verbunden.
    Wenn ich aber in /etc/resolv.conf 130.75.1.{32,40} als Nameserver eintrage, funktionieren die DNS-Anfragen wieder. Bestehende Verbindungen, die keine DNS-Anfragen benötige, sind von dem Problem daher nicht betroffen.

    Wie ist das Problem lösbar?
    Warum trat dieses Problem früher nicht auf?
    Hat vielleicht der VPN-Client schuld?

    Für jede Hilfe dankbar, Michael
tar: Anlegen eines leeren Archivs wird feige verweigert.

Shadow

... mit bunten Sternchen und so

  • "Shadow" is male

Posts: 838

Date of registration: Dec 21st 2001

Location: Hamburg

2

Monday, November 27th 2006, 5:41pm

Gib Deinem dhcpcd die Option -R mit auf den Weg, das hindert ihn daran, die Datei resolv.conv zu ändern.
"Man hält die Erzeugung von Information für ein Zeichen von Intelligenz, während in Wirklichkeit das Gegenteil richtig ist: Die Reduktion, die Auswahl der Information ist die viel höhere Leistung."
-- Heinz Zemanek

This post has been edited 1 times, last edit by "Shadow" (Nov 27th 2006, 5:42pm)


migu

free rider

  • "migu" is male
  • "migu" started this thread

Posts: 2,643

Date of registration: Dec 11th 2001

Occupation: Developer

3

Monday, November 27th 2006, 6:19pm

Quoted

Original von Shadow
Gib Deinem dhcpcd die Option -R mit auf den Weg, das hindert ihn daran, die Datei resolv.conv zu ändern.
Super! Danke! - Das werde ich gleich testen.
Ich dachte mir schon fast, dass es so einfach ist. ;)

EDIT: Bei mir läuft gar kein dhcpd. Ich muss es anders versuchen. Vielleicht könnte ich die leasetime ändern. Wie das in /etc/network/interfaces geht, weiß ich aber nicht. (?)
tar: Anlegen eines leeren Archivs wird feige verweigert.

This post has been edited 2 times, last edit by "migu" (Nov 27th 2006, 6:35pm)


dfex

Junior Schreiberling

  • "dfex" is male

Posts: 248

Date of registration: Dec 11th 2001

4

Monday, November 27th 2006, 7:39pm

Quoted

Original von migu
EDIT: Bei mir läuft gar kein dhcpd.

Auch wirklich kein dhcpcd ? ;) Oder hast du dich nur vertippt?

Shadow

... mit bunten Sternchen und so

  • "Shadow" is male

Posts: 838

Date of registration: Dec 21st 2001

Location: Hamburg

5

Monday, November 27th 2006, 8:52pm

Quoted

Original von migu
EDIT: Bei mir läuft gar kein dhcpd. Ich muss es anders versuchen. Vielleicht könnte ich die leasetime ändern. Wie das in /etc/network/interfaces geht, weiß ich aber nicht. (?)


Dann läuft wahrscheinlich ein dhclient, der macht das über resolvconv.

/usr/share/doc/resolvconf/README.gz sollte Dir helfen.

edit:
Folgende Zeile in der dhclient.conv sollte Dir helfen:
prepend domain-name-servers 130.75.1.40, 130.75.1.32;
"Man hält die Erzeugung von Information für ein Zeichen von Intelligenz, während in Wirklichkeit das Gegenteil richtig ist: Die Reduktion, die Auswahl der Information ist die viel höhere Leistung."
-- Heinz Zemanek

This post has been edited 2 times, last edit by "Shadow" (Nov 27th 2006, 9:01pm)


migu

free rider

  • "migu" is male
  • "migu" started this thread

Posts: 2,643

Date of registration: Dec 11th 2001

Occupation: Developer

6

Monday, November 27th 2006, 10:55pm

Quoted

Original von dfex

Quoted

Original von migu
EDIT: Bei mir läuft gar kein dhcpd.

Auch wirklich kein dhcpcd ? ;) Oder hast du dich nur vertippt?
Sicher kein dhcp(c)d. Unter ubuntu läuft standardmäßig nur ein dhclient3.

Quoted

Original von dfex
Dann läuft wahrscheinlich ein dhclient, der macht das über resolvconv.
Stimmt. s.o.

Quoted

/usr/share/doc/resolvconf/README.gz sollte Dir helfen.
Gibt's hier nicht. (egal)

Quoted

edit:
Folgende Zeile in der dhclient.conv sollte Dir helfen:
prepend domain-name-servers 130.75.1.40, 130.75.1.32;
Das 's mal 'n guter Tipp. Sieht vielversprechend aus.
Ich danke dir, äh, euch.
tar: Anlegen eines leeren Archivs wird feige verweigert.

This post has been edited 1 times, last edit by "migu" (Nov 27th 2006, 10:55pm)