You are not logged in.

schmaidt

Junior Schreiberling

  • "schmaidt" is male
  • "schmaidt" started this thread

Posts: 159

Date of registration: Feb 25th 2004

Location: Hannover

Occupation: Aus Interesse

1

Monday, September 29th 2008, 10:11am

OPENsuse 11.0 CPU-Auslastung

Hi,

ich habe mal wieder ein Linux-System (OpenSuse 11.0) bei mir installiert. Installation etc. ist ja auch echt einfach geworden. Wenn ich aber Linux bei mir Laufen habe, dann ist er tierisch langsam. Also selbst, wenn ich nur eine Konsole und Firefox mit 2 Tabs geöffnet habe, zwingt dass meinen Rechner komplett in die Knie. Das kann doch eigentlich nicht sein.

Ist das evtl. ein bekanntes Problem bei dem bekannten Release? Wie kann ich das in den Griff kriegen?

Danke, schmaidt
"Man kann beweisen, daß der technische Fortschritt besser ist mit Zucker!"
Ionesco, Die kahle Sängerin

Warui

Turner, Serveradmin & Workaholic

  • "Warui" is male

Posts: 717

Date of registration: Apr 25th 2006

Location: Südstadt

Occupation: (iter (B.Sc. Inf, 8)) \n (be-a-slave ("SRA", "Bachelor Thesis")) \n (be-a-programmer-slave ("Freelancer", "Programming"))

2

Monday, September 29th 2008, 10:16am

spontan würd ich ja sagen "bau dir deinen eigenen kernel" .... das hat bei SuSE schon immer Wunder gewirkt ;)
Erwachsenwerden? Ich mach ja viel Scheiß mit, aber nicht jeden!

hamena314

Zerschmetterling

  • "hamena314" is male

Posts: 2,032

Date of registration: Aug 31st 2003

Location: Hannover

Occupation: Informatikstudent (d'uh)

3

Monday, September 29th 2008, 2:55pm

Was für einen Rechner hast du denn?

HAVE PHUN!
Nicht der Wind bestimmt die Richtung, sondern das Segel! (Lao Xiang, China)

schmaidt

Junior Schreiberling

  • "schmaidt" is male
  • "schmaidt" started this thread

Posts: 159

Date of registration: Feb 25th 2004

Location: Hannover

Occupation: Aus Interesse

4

Tuesday, September 30th 2008, 8:54am

Intel Pentium M 1,73 GHz mit 1 GB Ram und ATI Mobility Radeon X700 mit 128 MB. Das ganze ist ein Asus A60000 Series Laptop.

Also ich glaube an mangelnder Hardware kann es nicht liegen, oder?
"Man kann beweisen, daß der technische Fortschritt besser ist mit Zucker!"
Ionesco, Die kahle Sängerin

schmaidt

Junior Schreiberling

  • "schmaidt" is male
  • "schmaidt" started this thread

Posts: 159

Date of registration: Feb 25th 2004

Location: Hannover

Occupation: Aus Interesse

5

Tuesday, September 30th 2008, 8:55am

spontan würd ich ja sagen "bau dir deinen eigenen kernel" .... das hat bei SuSE schon immer Wunder gewirkt ;)
Hmm, dafür reichen meine bescheidenen Linux-Kenntnisse nicht aus. Aber es muss ja eigentlich auch einen bestimmten Grund haben, dass er ununterbrochen rattert.
"Man kann beweisen, daß der technische Fortschritt besser ist mit Zucker!"
Ionesco, Die kahle Sängerin

  • "Joachim" is male

Posts: 2,863

Date of registration: Dec 11th 2001

Location: Hämelerwald

Occupation: Wissenschaftlicher Mitarbeiter (Forschungszentrum L3S, TU Braunschweig)

6

Tuesday, September 30th 2008, 9:06am

spontan würd ich ja sagen "bau dir deinen eigenen kernel" ....
Spontan würde ich sagen: Bloß nicht auf gut Glück am Kernel rumfummeln. Lieber erstmal schauen, was das System tatsächlich so langsam macht. Laufen vielleicht irgendwelche Prozesse im Hintergrund, die ordentlich CPU-Zeit fressen ("top" gibt darüber Auskunft)?
The purpose of computing is insight, not numbers.
Richard Hamming, 1962

Benjamin

Segelnder Alter Hase

  • "Benjamin" is male

Posts: 3,827

Date of registration: Oct 1st 2002

Location: Region Hannover

Occupation: Alumni

7

Tuesday, September 30th 2008, 9:28am

Wollt ich gerade sagen. Sind die Zeiten von Back dir deinen eigenen Kernel nicht eigentlich vorbei, wenn man nicht gerade im embedded Bereich zugange ist? Früher war das ja fast ein Hobby, doch da dauerte das auch noch angemessen lange. Heut muss man den doch eigentlich nicht mehr anfassen, außer man muss spezielle Erweiterungen hineinbauen, die es von Haus aus nicht gibt, was bei einem Standardnotebook eher nicht der Fall sein sollte. Wobei so verkrampft wie Joachim würd ich das mit dem Kernel nun auch nicht sehen. Aber, hör auf Joachim und suche lieber erstmal im user space. ATI Mobility... schlechter Standardgrakatreiber der dann mit irgendetwas zusammen das System in die Knie zwingt? Ich erinner mich einen Core2Duo mit einer ATI-Karte genau aus diesem Grund unbenutzbar langsam gehabt zu haben. Hat OpenSuse einen der 3D-Desktops dabei? Das letzte neue KDE wurde auch unbenutzbar wagte man es, die Transparenzunterstützung oder so anzuschalten auf so mancher Maschine (mit schlechtem ATI-Treiber).
Es gibt nur eine bessere Sache als auf dem Wasser zu sein: Noch mehr auf dem Wasser sein.

Warui

Turner, Serveradmin & Workaholic

  • "Warui" is male

Posts: 717

Date of registration: Apr 25th 2006

Location: Südstadt

Occupation: (iter (B.Sc. Inf, 8)) \n (be-a-slave ("SRA", "Bachelor Thesis")) \n (be-a-programmer-slave ("Freelancer", "Programming"))

8

Tuesday, September 30th 2008, 11:38am

spontan würd ich ja sagen "bau dir deinen eigenen kernel" ....
Spontan würde ich sagen: Bloß nicht auf gut Glück am Kernel rumfummeln. Lieber erstmal schauen, was das System tatsächlich so langsam macht. Laufen vielleicht irgendwelche Prozesse im Hintergrund, die ordentlich CPU-Zeit fressen ("top" gibt darüber Auskunft)?


ok, genug Ahnung vorausgesetzt natürlich .... du kommst ja auch nicht auf den gedanken, an nem motor rumzuschrauben, ohne zu wissen, was du da tust ;)
Erwachsenwerden? Ich mach ja viel Scheiß mit, aber nicht jeden!

Rick

Mädchen

  • "Rick" is male

Posts: 1,266

Date of registration: Mar 17th 2004

Location: ::1/128

Occupation: Forentroll

9

Tuesday, September 30th 2008, 11:58am

erstmal mit top schauen wo die cycles hinverschwinden.
Wenn die in nem kthread enden, dann isses wohl der kernel. Wenn nicht ist nur irgendein user space programm am durchgehen.
Wenn's ein kthread ist, eben den kernel von Hand bauen (make menuconfig im sourcetree und eben ein paar Häkchen setzen, das erste mal dauert vielleicht zwei, drei Stunden, aber danach hat ma ja ne config datei und die nächsten male gehen flott) und schaun ob das hilft, sonst vielleicht ne aktuelle kernel.org version probieren oder schaun ob es irgendwo nen treiber patch gibt.
Und Kernel bauen ist nun wirklich keine hohe Kunst, die größte Gefahr ist dass man sich's mit dem Bootloader verscherzt.

Naja, viel Erfolg auf jeden Fall bei der Fehlersuche.

Sometimes you've got to ask yourself: Is xkcd shitty today?

Schard

Trainee

  • "Schard" is male

Posts: 37

Date of registration: Oct 3rd 2007

Location: Erde

Occupation: HiWi am IKT

10

Tuesday, September 30th 2008, 9:48pm

ATI GraKa?
Dann isset mit 99%iger W'keit nen fehlender Treiber.
Was sagt denn "sysinfo:/" (der Arbeitsplatz) zu GraKa Treibern?
Da sollte was von "fglrx" stehen o.ä.

LG, Schard.

Zitat von »Commander Sing Bex: "The Art of Secrets". Approx. CY 2575«


The loyal heart
Has hidden treasures.
In secrets kept,
In silence sealed.

Philipp

Praktikant

  • "Philipp" is male

Posts: 13

Date of registration: Nov 11th 2006

11

Wednesday, October 1st 2008, 12:00pm

@schmaidt

Ich kann mich erinnern, das am Anfang bei neueren SuSE Systemen beagle-index und zen-updater durchlaufen, die die ersten 2-3h nach der Installation das System erstmal lahm legen.
Ansonsten rate ich dir auch erstmal kurz "top" oder ähnliches auszuführen um die CPU-/Speicher Fresser zu ermitteln ( In KDE kannst du auch STRG+ESC drücken, dann gibt es eine ähnliche grafische Übersicht wie der Taskmanager unter Windows ).
Welche Oberfläche benutzt du denn? KDE/GNOME? Mal geguckt wie die Performance des Systems ohne grafische Oberfläche ist?

Gruß
Philipp
Mögen all deine Träume sich erfüllen, Träumer; mögen sie dir stets Glück und Erkenntnis bringen. ( Sergio Bambaren, Der träumende Delphin )

This post has been edited 1 times, last edit by "Philipp" (Oct 1st 2008, 12:01pm)


schmaidt

Junior Schreiberling

  • "schmaidt" is male
  • "schmaidt" started this thread

Posts: 159

Date of registration: Feb 25th 2004

Location: Hannover

Occupation: Aus Interesse

12

Wednesday, October 1st 2008, 5:08pm

ATI GraKa?
Dann isset mit 99%iger W'keit nen fehlender Treiber.
Was sagt denn "sysinfo:/" (der Arbeitsplatz) zu GraKa Treibern?
Da sollte was von "fglrx" stehen o.ä.

LG, Schard.
Also da steht bei mir folgendes:

Hersteller: ATI Technologies Inc.
Modell: Mobility Radeon X700 5653 (M26) (PCIE)
Treiber: radeon (3D-Unterstützung)

Liegt da das Problem? Also von flgrx steht da nichts?
"Man kann beweisen, daß der technische Fortschritt besser ist mit Zucker!"
Ionesco, Die kahle Sängerin

schmaidt

Junior Schreiberling

  • "schmaidt" is male
  • "schmaidt" started this thread

Posts: 159

Date of registration: Feb 25th 2004

Location: Hannover

Occupation: Aus Interesse

13

Wednesday, October 1st 2008, 5:16pm

@schmaidt

Ich kann mich erinnern, das am Anfang bei neueren SuSE Systemen beagle-index und zen-updater durchlaufen, die die ersten 2-3h nach der Installation das System erstmal lahm legen.
Ansonsten rate ich dir auch erstmal kurz "top" oder ähnliches auszuführen um die CPU-/Speicher Fresser zu ermitteln ( In KDE kannst du auch STRG+ESC drücken, dann gibt es eine ähnliche grafische Übersicht wie der Taskmanager unter Windows ).
Welche Oberfläche benutzt du denn? KDE/GNOME? Mal geguckt wie die Performance des Systems ohne grafische Oberfläche ist?

Gruß
Philipp
Also ich nutze KDE. Im Process-Table (KDE -> STRG-ESC) weiß ich nicht, was die ganzen Tabellenspalten bedeuten (Vm, VmRss, VmURss). Auf jeden Fall haben beagled und beagled-helper mit 7 bzw. 19 sehr hohe Prioritäten (der Rest ist alles bei Null, habe aber gerade auch nur ein Firefox-Tab offen).

Was ist beagle?
"Man kann beweisen, daß der technische Fortschritt besser ist mit Zucker!"
Ionesco, Die kahle Sängerin

oixio

Senior Schreiberling

  • "oixio" is male

Posts: 517

Date of registration: Oct 3rd 2004

14

Wednesday, October 1st 2008, 5:19pm

Was ist beagle?

Eine Desktopsuchmaschine, die mit einem Dateiindex arbeitet. Siehe Wikipedia.org: Beagle_(Software)
Dieser Post wurde aus 100 % chlorfrei gebleichten, handelsüblichen, freilaufenden, glücklichen Elektronen erzeugt!

schmaidt

Junior Schreiberling

  • "schmaidt" is male
  • "schmaidt" started this thread

Posts: 159

Date of registration: Feb 25th 2004

Location: Hannover

Occupation: Aus Interesse

15

Thursday, October 2nd 2008, 9:18am

Also ich glaube ich habe den Missetäter identifiziert: Firefox!

Ich browse jetzt seit einer knappen Stunde mit dem Konqueror und er rattert nicht mehr wie verrückt!

Ist das etwa ein bekanntes Problem? Ich würde es zumindest ganz gerne beheben, da ich ganz gerne mit Firefox unterwegs bin!
"Man kann beweisen, daß der technische Fortschritt besser ist mit Zucker!"
Ionesco, Die kahle Sängerin

Benjamin

Segelnder Alter Hase

  • "Benjamin" is male

Posts: 3,827

Date of registration: Oct 1st 2002

Location: Region Hannover

Occupation: Alumni

16

Thursday, October 2nd 2008, 9:45am

Ich tippe immernoch auf den GraKa-Treiber. Firefox ruckelt sogar unter Windows mit schlechtem Treiber...

Fehlerhafte 3D-Beschleunigung mit opensource radeon-treiber

Ein Haufen Probleme wirst Du dort bei der Suche nach radeon finden, Lösungen ggf. mit der Suche nach fglrx, z. B. soetwas wie ATI Mobility X700 Treiber
Es gibt nur eine bessere Sache als auf dem Wasser zu sein: Noch mehr auf dem Wasser sein.

schmaidt

Junior Schreiberling

  • "schmaidt" is male
  • "schmaidt" started this thread

Posts: 159

Date of registration: Feb 25th 2004

Location: Hannover

Occupation: Aus Interesse

17

Wednesday, October 8th 2008, 5:29pm

Also ich glaube nicht, dass es am Grafiktreiber liegt. Habe jetzt nochmal gemäß dieser Seite die neuesten ATI-Treiber installiert. Danach habe ich unter sysinfo die richtige Grafikkarte stehen und auch den fglrx-Treiber mit aktivierter 3D-Unterstützung. Auch fglrxinfo liefert den richtigen Output und die Räder unter fgl_glxgears drehen sich auch optimal flott. Nach wie vor ist es aber so, dass Firefox tierisch quält und auch unter top die höchsten Werte hat (5-10$ CPU und 5-10% Mem mit deutlichen Ausreißern nach oben).

Hat noch wer eine Idee?
"Man kann beweisen, daß der technische Fortschritt besser ist mit Zucker!"
Ionesco, Die kahle Sängerin

oixio

Senior Schreiberling

  • "oixio" is male

Posts: 517

Date of registration: Oct 3rd 2004

18

Wednesday, October 8th 2008, 5:40pm

Hmm - in den eeePC-Foren ließt man häufiger, dass man in Firefox den Schutz vor bösartigen Websites ausstellen soll, da dadurch auf der schwachen Hardware "Denkpausen" verursacht werden. Das sollte auf deiner Hardware nicht viel ausmachen, aber probieren kannst du es ja mal.

Zu finden unter "Einstellungen" --> Sicherheit --> Hinweis anzeigen, ..... (da beide Haken rausmachen).

Macht natürlich nur Sinn, falls wirklich nur der Firefox betroffen ist. Wo wir grade dabei sind: Hast du irgendwelche Addons installiert? z.B. Adblock ist für hohe Systemlast bekannt.


Und ein Test mit einer anderen Linux-Distribution per Live-CD könnte vielleicht auch nicht schaden.
Dieser Post wurde aus 100 % chlorfrei gebleichten, handelsüblichen, freilaufenden, glücklichen Elektronen erzeugt!

schmaidt

Junior Schreiberling

  • "schmaidt" is male
  • "schmaidt" started this thread

Posts: 159

Date of registration: Feb 25th 2004

Location: Hannover

Occupation: Aus Interesse

19

Wednesday, October 8th 2008, 5:46pm

Hmm, also ich habe jetzt einfach nochmal Firefox via Yast gelöscht und mir die Version von der Mozilla Firefox-Seite runtergeladen. Seitdem funktioniert das ganze eigentlich ganz gut. Zumindest ruckelt hier nichts mehr und so ... Mal gucken, vielleicht lag es wirklich einfach an einer komischer Installation von Firefox!?!

Ich gucke nochmal, wie es sich so die nächsten Tage entwickelt und schreibe hier ggbf. nochmal rein, ob das Problem jetzt als "behoben" gilt oder ich weiter unzufrieden bin!

Zunächst aber Danke an alle!
"Man kann beweisen, daß der technische Fortschritt besser ist mit Zucker!"
Ionesco, Die kahle Sängerin

schmaidt

Junior Schreiberling

  • "schmaidt" is male
  • "schmaidt" started this thread

Posts: 159

Date of registration: Feb 25th 2004

Location: Hannover

Occupation: Aus Interesse

20

Friday, October 10th 2008, 10:37am

Also es muss irgendwie an der Installation gelegen haben. Mit der neuen funktioniert alles in normaler Geschwindigkeit.
"Man kann beweisen, daß der technische Fortschritt besser ist mit Zucker!"
Ionesco, Die kahle Sängerin