You are not logged in.

cowhen

Muuuh!

  • "cowhen" is male
  • "cowhen" started this thread

Posts: 1,374

Date of registration: Dec 13th 2001

1

Thursday, December 26th 2002, 11:51am

Linux ACPI Stromspar-Tips?

Hallo,

ich habe auf meinem Laptop jetzt Linux (Suse 8.1) mit ACPI ans laufen bekommen. Er unterstützt C1 und C2, acht Throttling-Stufen, die Batterieanzeige mit aKpi funktioniert auch. Ich habe das HD-Powerdown auf 1 Min gestellt. Hat jemand hier schon Erfahrung mit Linux und ACPI aufm Notebook und kann mit Tips geben, wie ich die Akkulaufzeit maximiere? Das wäre super!

thx

cowhen
plenty of time to relax when you are dead

luzifah

Trainee

  • "luzifah" is male

Posts: 64

Date of registration: Jan 6th 2002

Location: Laatzen

2

Thursday, December 26th 2002, 1:50pm

moin,

so weit läuft das bei mir auch , auch mit deb. .
wie gross ist denn jetzt bei dir der unterschied zu win ?
also so wie ich das sehe muss man den entwicklern echt noch nen paar wochen geben, weil das gelbe vom ei ist das noch nicht :(

zusätzlich hab ich noch das thermal modul geladen ( scheint auch alles zu funzen, also auch die luefter steuerung, die hatte mir nämlich auch am anfang ärger gemacht).

p.s. hast du jetzt das sonypi modul laden koennen ( also fuer die fx ) tasten ?

so far tobi

cowhen

Muuuh!

  • "cowhen" is male
  • "cowhen" started this thread

Posts: 1,374

Date of registration: Dec 13th 2001

3

Thursday, December 26th 2002, 2:41pm

Quoted

p.s. hast du jetzt das sonypi modul laden koennen ( also fuer die fx ) tasten ?
ne was ist das? wo bekommt man das?

laufzeitunterschied zu windows kann ich noch nicht sagen: bin gerade am testen hatte bis jetz immer das netzteil dran. auf jeden fall ist die akku-anzeige und win und linux nicht linear. er wird angeblich zuerst ganz schnell leer und dann immerlangsamer. kann man das (unter linux) irgendwie korrigren?


cu

cowhen
plenty of time to relax when you are dead

Shadow

... mit bunten Sternchen und so

  • "Shadow" is male

Posts: 838

Date of registration: Dec 21st 2001

Location: Hamburg

4

Thursday, December 26th 2002, 3:47pm

Akku-Anzeige:
Nein, kann man nicht. Ein ACPI-Akku sagt selbst, wie voll er noch ist. Um das zu korrigieren müsstest Du das ACPI-Modul selbst manipulieren und irgendwie die Angaben, die der Akku macht in eigene umrechnen.

Stromspar-Tipps:
Ich habe zusätzlich zum Platten-Timeout von 3 min noch ein extem agressives Write-behind-Caching aktiviert. Mein System hält Daten bis zu 10 Minuten im RAM bis es sie wegschreibt. Das hindert die Platte am häufigen Hochdrehen. Die Datensicherheit beim Absturz ist dann natürlich nicht mehr die höchste. Wichtig ist dann auch, dass Du auf jeden Fall ein journaling FS verwendest (z.B. reiser, ext3, jfs, xfs).

Wenn Du Debian einsetzen würdest wäre eine Möglichkeit / und /var in eine RAMdisk zu laden und /usr readonly zu mounten, dann müsste Dein Rechner im "normalen Betrieb" die Platte gar nicht mehr hochdrehen, wenn alle benötigten Programme und Bibliotheken geladen sind. Bei SuSE würde ich das nicht versuchen, da SuSE im Regelbetrieb auf /usr/ schreibend zugreift. (Zumindest unter 7.2 war das noch so, damit hatte ich nämlich mal tierische Probleme...)
Ansonsten: So oft wie möglich das Display-Backlight abschaten lassen, wenn es nicht gebraucht wird, das verbraucht nämlich einen guten Teil der Energie.
Selbstredend, dass Plattenintensive und Rechenintensive Prozesse (updatedb etc.) im Batteriebetrieb nix verloren haben.

Gruß
Shadow
"Man hält die Erzeugung von Information für ein Zeichen von Intelligenz, während in Wirklichkeit das Gegenteil richtig ist: Die Reduktion, die Auswahl der Information ist die viel höhere Leistung."
-- Heinz Zemanek

luzifah

Trainee

  • "luzifah" is male

Posts: 64

Date of registration: Jan 6th 2002

Location: Laatzen

5

Thursday, December 26th 2002, 4:15pm

Quoted

p.s. hast du jetzt das sonypi modul laden koennen ( also fuer die fx ) tasten ?

ne was ist das? wo bekommt man das?


.. ist ein kernel modul im standart kernel vorhanden unter:

Character devices -> Sony Vaio Programmable I/O Control Device support

ich bekomme ein request region failed ? kannst du ja mal ausprobieren....

so far

cowhen

Muuuh!

  • "cowhen" is male
  • "cowhen" started this thread

Posts: 1,374

Date of registration: Dec 13th 2001

6

Thursday, December 26th 2002, 7:54pm

sonypi

also ich konnte mit

modprobe sonypi

das modul laden (es wird jetz auch bei lsmod aufgeführt) aber... die fn-taste macht nix.... wie solls jetzt weitergehen? sollte man jetz irgendwie die helligkeit usw regeln können?


cu

cowhen
plenty of time to relax when you are dead

luzifah

Trainee

  • "luzifah" is male

Posts: 64

Date of registration: Jan 6th 2002

Location: Laatzen

7

Thursday, December 26th 2002, 7:57pm

ja,

mit spicctrl

damit sollte man dann die helligkeit steuern koennen, wie gesagt ich kann das mistding nicht laden ich weiss auch nicht warum :)


spicctrl ist im apt verfügbar bei deinem suse musste du mal schauen

so far

ps. welchen kernel hast du genommen 2.4.20 ?

cowhen

Muuuh!

  • "cowhen" is male
  • "cowhen" started this thread

Posts: 1,374

Date of registration: Dec 13th 2001

8

Friday, December 27th 2002, 11:16am

hi

spicctrl habe ich nicht. muss ich gleich mal nach schauen.

noch ein anderes problem: ich will die harddisk ja nicht ständig laufen lassen. aber irgendwie schaltet sie sich nicht ab. ich glaube irgendwas greift ca. alle 30 sec darauf zu :( . hier die werte mit denen ichs probiert habe (sind die vielleicht quatsch?)

apmd_adjust_disk_perf = yes
apmd_battery_data_timeout = 300
apmd_battery_disk_timeout = 12
apmd_battery_fill_level = 90
apmd_battery_kupdate_intervall = 120
apmd_check_time = 0

wäre dankbar für hilfe!

[ edit: achso, außerdem bekomme ich das tft nciht abgeschaltet. ich habe diese energy(tm) kontrolle versucht, was auf meinen desktop pc auch super funktioniert aber das tft schaltet sich nicht aus :o ]

thx

cowhen

ps: @ luzi: habe kernel 2.4.19
plenty of time to relax when you are dead

cowhen

Muuuh!

  • "cowhen" is male
  • "cowhen" started this thread

Posts: 1,374

Date of registration: Dec 13th 2001

9

Friday, December 27th 2002, 4:56pm

hallo nochmal,

das harddisk problem hat sich erledigt. das geht jetz auch :)

bleibt nurnoch das problem mit dem tft-backlight das ich nicht abschalten kann. wäre dazu weiterhin für tips dankbar.
edit: funktioniert jetz auch, hat an der falschen einstellung für den monitor gelegen...


und @luzifah: spicctrl funktioniert bei mir jetz auch um die helligkeit zu regeln.


mfg

cowhen
plenty of time to relax when you are dead

AnyKey

Erfahrener Schreiberling

Posts: 451

Date of registration: Dec 11th 2001

Location: H-Town

Occupation: Student

10

Tuesday, December 31st 2002, 2:03pm

Ich hätt da auch gern nochmal ne Frage:

Ich habe den 2.4.20 kernel compiliert und bin soweit auch zufrieden, nur ein:

shutdown -h now

fährt den rechner zwar runter, aber er schaltet sich nicht aus!?

Ich habe nun schon in "General Setup" das "Power Management support" angeschaltet, und "Advanced Power Management BIOS support" als Modul compiliert.

Beim zweiten habe ich auch "Use real mode APM BIOS call to power off" angekreuzt.

Dies alles hat aber nicht geholfen.

Hat einer nen tip??

"Der Mensch braucht Schubladen." -- Any Key

  • "Joachim" is male

Posts: 2,863

Date of registration: Dec 11th 2001

Location: Hämelerwald

Occupation: Wissenschaftlicher Mitarbeiter (Forschungszentrum L3S, TU Braunschweig)

11

Tuesday, December 31st 2002, 3:26pm

Quoted

Original von AnyKey
Ich habe den 2.4.20 kernel compiliert und bin soweit auch zufrieden, nur ein:

shutdown -h now

fährt den rechner zwar runter, aber er schaltet sich nicht aus!?

Ich habe nun schon in "General Setup" das "Power Management support" angeschaltet, und "Advanced Power Management BIOS support" als Modul compiliert.

Beim zweiten habe ich auch "Use real mode APM BIOS call to power off" angekreuzt.
Unterstützt der Rechner denn überhaupt APM? Wird das APM-Modul korrekt geladen? Falls nein, dann mußt du es mit ACPI versuchen (das macht dann einen Kernel-Patch erforderlich). Viele aktuelle Rechner unterstützen nämlich kein APM mehr, sondern nur noch ACPI.
The purpose of computing is insight, not numbers.
Richard Hamming, 1962

Shadow

... mit bunten Sternchen und so

  • "Shadow" is male

Posts: 838

Date of registration: Dec 21st 2001

Location: Hamburg

12

Tuesday, December 31st 2002, 10:49pm

Im 2.4.20 ist ACPI jetzt offiziell enthalten. Du musst nur "Prompt for developement and/or incomplete modules/drivers" einschalten.

Aber ich hab auch noch ne Frage zum ACPI:
Auf mein em Laptop läuft inzwischen auch ACPI; Batterie-, CPU-Temeraturanzeige usw. funktionieren auch problemlos, boß wenn ich den Rechner in einen beliebigen Stromsparmodus versetze passieren ungewöhnliche Dinge.
Mein System unterstützt laut BIOS die Stromsparmodi S3 und S4 (Suspend-to-RAM und Suspend-to-Disk; S0 ist normaler Betrieb, S5 ist Power down):
[snip]
sunstar:~# cat /proc/acpi/sleep
S0 S3 S4 S5
[snap]
Wenn ich jetzt in den S3 schalte (echo 3 > /proc/acpi/sleep), dann sieht erst alles ganz normal aus. Das System schaltet wie unter Windows Platte, Lüfter, Display und Peripherie ab und geht in den S3, wenn ich den Power-Knopf dann drücke wacht es aber nicht mehr richtig auf:
Der Bilschirminhalt wird zwar wiederhergestellt, Lüfter und Platte laufen wieder an, aber die Power-LED blinkt weiter und Tastatureingaben sind nicht möglich.
Der S4 verhält sich noch komischer: Er wirkt wie der S5 und schaltet das System ohne Vorwarnung aus.

Solutions?

Shadow
"Man hält die Erzeugung von Information für ein Zeichen von Intelligenz, während in Wirklichkeit das Gegenteil richtig ist: Die Reduktion, die Auswahl der Information ist die viel höhere Leistung."
-- Heinz Zemanek

cowhen

Muuuh!

  • "cowhen" is male
  • "cowhen" started this thread

Posts: 1,374

Date of registration: Dec 13th 2001

13

Wednesday, January 1st 2003, 12:26pm

Hallo Shadow,

habe ein ganz ähnliches Problem. Aber erstmal:

Laut c't 25/2005 S. 235 unterstützt Linux derzeit nur den S1 Zustand.
Aber bei mir funktioniert der auch nicht richtig...

mit echo 1 > /proc/acpi/sleep

geht der Rechner zwar in einen Ruhezustand aber er lässt sich durch nichts bewegen, wieder hochzufahren. :o

Geht S1 bei dir denn korrekt? Achne der wird ja angeblich bei dir garnicht unerstützt. Angeblich sollte Bios-Updates in solchen Fällen ja Wunder bewirken. Habe es aber noch nicht gewagt.


cu

cowhen

ps: meiner unterstützt laut bios: S0 S1 S3 S4 S5
pps: Und könnte mir jemand mal sagen, was man unter Linux als Gateway/DNS einstellen muss, damit man das UHWLAN nutzen kann?? thx.
plenty of time to relax when you are dead

EvilHomer

Junior Schreiberling

  • "EvilHomer" is male

Posts: 214

Date of registration: Dec 12th 2001

Location: Region Hannover

Occupation: Da kommt Ihr nie drauf ;-)

14

Wednesday, January 1st 2003, 1:25pm

Quoted

Original von cowhen
pps: Und könnte mir jemand mal sagen, was man unter Linux als Gateway/DNS einstellen muss, damit man das UHWLAN nutzen kann?? thx.



Vieleicht 192.168.10.3, wie es auf http://www.rrzn.uni-hannover.de/Netz/vpn/ beschrieben wird.

cu EH

When people look like ants - pull
When ants look like people - pray


Shadow

... mit bunten Sternchen und so

  • "Shadow" is male

Posts: 838

Date of registration: Dec 21st 2001

Location: Hamburg

15

Wednesday, January 1st 2003, 10:44pm

Quoted

Original von cowhen
pps: Und könnte mir jemand mal sagen, was man unter Linux als Gateway/DNS einstellen muss, damit man das UHWLAN nutzen kann?? thx.


Gar nichts.
Der VPN Gateway ist im lokalen Netz (Gleiche Broadcast Domain, OSI Layer 2) zu erreichen, damit brauchts keinen Default Gateway.
Alles andere macht ja der VPN-Client, Du bekommst also eine "echte" IP (130.75.x.y) und ums Routing kümmert sich der VPN-Accessconcentrator. So einfach ist das...

Shadow
"Man hält die Erzeugung von Information für ein Zeichen von Intelligenz, während in Wirklichkeit das Gegenteil richtig ist: Die Reduktion, die Auswahl der Information ist die viel höhere Leistung."
-- Heinz Zemanek

AnyKey

Erfahrener Schreiberling

Posts: 451

Date of registration: Dec 11th 2001

Location: H-Town

Occupation: Student

16

Thursday, January 2nd 2003, 7:46pm

Quoted

Im 2.4.20 ist ACPI jetzt offiziell enthalten. Du musst nur "Prompt for developement and/or incomplete modules/drivers" einschalten.


Ok das habe ich gemacht, und ausserdem in den General Settings -->
...
[*] Power Management support
[*] ACPI support
[ ] ACPI Debug Statements
<M> ACPI Bus Manager
<M> System
<M> Processor
<M> Button
<M> AC Adapter
<M> Embedded Controller
<M> Control Method Battery
<M> Thermal
< > Advanced Power Management BIOS support

dieses aktiviert.
Das ganze will aber trotzdem nicht funktionieren!
Haben die Suseleute da was besonderes in den Kernelgepatcht??

"Der Mensch braucht Schubladen." -- Any Key

luzifah

Trainee

  • "luzifah" is male

Posts: 64

Date of registration: Jan 6th 2002

Location: Laatzen

17

Friday, January 3rd 2003, 9:57am

ich habe den 2.4.19 mit dem neuesten acpi patch damit läuft das, allerdings kann ich wie gesagt das sonypi modul nicht laden und werde deshalb den 2.4.20 jetzt am we nochmal prob.

so far