Sie sind nicht angemeldet.

Alarion

Trainee

  • »Alarion« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 30.09.2009

1

20.06.2012, 19:58

Eclipse für das Labor Grafikprogrammierung einrichten (Windows)

So, nach dem dritten komplett verschwendeten Tag bin ich etwas gefrustet. Hat es irgendjemand der Windows Nutzer geschafft, sein Eclipse für das Grafiklabor einzurichten?

Ich bin dieser Anleitung hier gefolgt:

-CDT Plugin für Eclipse installiert
-MinGW/MSys Compiler installiert
-WxWidgets installiert und kompiliert

Ich kann einfache C++ Programme erstellen und kompilieren und auch das wxWidgets Testprogramm aus der Anleitung oben. Aber wenn ich das gdv_src Paket importiere, werden mir immer noch stolze 155 Fehler angezeigt, aus denen ich als C++ Noob natürlich nicht schlau werde. Hier mal ein Ausschnitt.

Hat irgendjemand möglicherweise vor demselben Problem gestanden und eine Lösung gefunden?

Grüße,
Daniel

  • »Schokoholic« ist männlich

Beiträge: 2 516

Registrierungsdatum: 04.10.2006

Wohnort: Hannover

Beruf: Haarspaltung

2

20.06.2012, 21:18

Hm, Anhand der Bezeichner, die offenbar nicht definiert sind, würde ich sagen, dass der Compiler die OpenGL-Headerdateien nicht findet. Gibt es denn irgendwelche Fehlermeldungen zu nicht gefundenen Dateien?

SammysHP

Forenwolf

  • »SammysHP« ist männlich

Beiträge: 711

Registrierungsdatum: 11.10.2010

Wohnort: Celle

Beruf: Informatiker

3

20.06.2012, 21:31

Auch, wenn ich nicht weiß, worum es im Labor geht: Wie wär's mit einer virtuellen (Linux-)Maschine?

  • »Schokoholic« ist männlich

Beiträge: 2 516

Registrierungsdatum: 04.10.2006

Wohnort: Hannover

Beruf: Haarspaltung

4

20.06.2012, 21:39

Auch, wenn ich nicht weiß, worum es im Labor geht: Wie wär's mit einer virtuellen (Linux-)Maschine?

Ja, das hab ich damals auch gemacht, mit coLinux.

Finn MacCool

Junior Schreiberling

Beiträge: 195

Registrierungsdatum: 07.10.2006

5

20.06.2012, 22:31

ich meine mich von meinem versuch mit cdt her noch dunkel zu erinnern, dass die einführung einiger umgebungsvariablen zur umstellung der verwendeten sprache bei einigen problemen helfen kann.
So berichte uns weiter, sagte Diarmuid Donn, um der Liebe Gottes willen.
Fürwahr, sagte Finn, ich will nicht.

SammysHP

Forenwolf

  • »SammysHP« ist männlich

Beiträge: 711

Registrierungsdatum: 11.10.2010

Wohnort: Celle

Beruf: Informatiker

6

20.06.2012, 23:09

Also coLinux klingt irgendwie ganz schön fies, das würde ich meinem Windows nicht zumuten. :/ Ich dachte eher an VirtualBox o.ä. (Was ich vermutlich nutzen würde, wenn ich coLinux probieren würde. :D)

nano

Alter Hase

  • »nano« ist männlich

Beiträge: 146

Registrierungsdatum: 11.10.2010

Wohnort: Hannover

Beruf: THI

7

21.06.2012, 08:54

Die wxWidgets-Headers fehlen aber auch. (GetClientSize, Close)
Insofern scheint noch einiges an den Includepfaden kaputt zu sein. Hast du versucht, die in den Projekteinstellungen zu setzen?

XAX

Junior Schreiberling

  • »XAX« ist männlich

Beiträge: 207

Registrierungsdatum: 25.12.2004

8

21.06.2012, 12:04

Ich habe das damals mit dem Visual Studio (MSDNAA) gemacht. Die vorkompilierten wxWidgets für Windows installiert.
Dann musste man "nur" noch einige Umgebungsvariablen setzen und es lief. Kann es im detail nicht mehr beschreiben.
Aber vielleicht geht es einfacher als mit Eclipse.

Alarion

Trainee

  • »Alarion« ist der Autor dieses Themas

Beiträge: 71

Registrierungsdatum: 30.09.2009

9

24.06.2012, 16:18

Danke für die Antworten!

Hm, Anhand der Bezeichner, die offenbar nicht definiert sind, würde ich sagen, dass der Compiler die OpenGL-Headerdateien nicht findet. Gibt es denn irgendwelche Fehlermeldungen zu nicht gefundenen Dateien?

Ah, tatsächlich, hier: #include <GL/glew.h> *no such file or directory*, hm du weißt nicht zufällig wo ich das herbekomme und wie ich es einbinde?


Die wxWidgets-Headers fehlen aber auch. (GetClientSize, Close)
Insofern scheint noch einiges an den Includepfaden kaputt zu sein. Hast du versucht, die in den Projekteinstellungen zu setzen?

Jo, hab ich entsprechend der Anleitung oben gemacht. Ob das ausreichend war, ist natürlich ne andere Frage :D Zumindest meckert er bei den wx includes auch nicht explizit und auch ein wxWidgets Testprogramm konnte ich problemlos importieren. So sieht das aus, was ich da in den Projekteinstellungen gesetzt hab: Screenshot


Auch, wenn ich nicht weiß, worum es im Labor geht: Wie wär's mit einer virtuellen (Linux-)Maschine?

Also wenn es bis Mittwoch noch nicht läuft nehm ich die VirtualBox ^^

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Alarion« (24.06.2012, 17:54)


  • »Schokoholic« ist männlich

Beiträge: 2 516

Registrierungsdatum: 04.10.2006

Wohnort: Hannover

Beruf: Haarspaltung

10

26.06.2012, 11:30

Ah, tatsächlich, hier: #include <GL/glew.h> *no such file or directory*, hm du weißt nicht zufällig wo ich das herbekomme und wie ich es einbinde?

Ne, müsste ich jetzt auch googlen.

ProNoob

Trainee

  • »ProNoob« ist männlich

Beiträge: 72

Registrierungsdatum: 01.10.2010

Wohnort: Hannover

11

26.06.2012, 14:50

http://glew.sourceforge.net/

Damit haben wir versucht das ganze zum Laufen zu kriegen. Hat zwar einige Fehler behoben, aber nicht alle.
Dabei scheint es wohl so (meinem Kommilitonen ist das aufgefallen), dass die Binaries nur für Microsoft Visual Studio vorliegen, d.h. für den "normalen" gebrauch gesondert compiliert werden müssen....