Sie sind nicht angemeldet.

Scirocco81

Zuhörer

  • »Scirocco81« ist männlich
  • »Scirocco81« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 13.12.2005

1

13.12.2005, 09:27

mssql_query(): BIG PROBLEM

Ich bekomme folgende Fehlermeldung:
mssql_query(): supplied argument is not a valid MS SQL-Link resource
in ....

quelltext ist folgender:

Quellcode

1
2
3
4
5
	$poll_result = mssql_query($poll_dbName, "SELECT * FROM $poll_descTableName"); 
	if(!$poll_result)
	{
		echo mssql_errno(). ": ".mssql_error(). "<br>";
		return;

brauche dringend hilfe

Scirocco81

Zuhörer

  • »Scirocco81« ist männlich
  • »Scirocco81« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 13.12.2005

2

13.12.2005, 09:36

RE: mssql_query(): BIG PROBLEM

hab hier noch ne meldung:

Warning: mssql_query(): supplied argument is not a valid MS SQL-Link resource in *****.php on line 91

Fatal error: Call to undefined function mssql_errno() in *****.php on line 94


vielleicht hilft es ja weiter zur behebung

3

13.12.2005, 12:02

Müsste das erste Argument nicht eine Verbindungskennung sein und kein Datenbankname? Oder heißt die Variable bloß schlecht?

// Edit: Andersrum :P Einfach mal die Doku lesen ...

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »maffe« (13.12.2005, 12:03)


Scirocco81

Zuhörer

  • »Scirocco81« ist männlich
  • »Scirocco81« ist der Autor dieses Themas

Beiträge: 3

Registrierungsdatum: 13.12.2005

4

13.12.2005, 12:45

hier ist der quelltext der davor noch steht:

Quellcode

1
2
3
4
5
6
7
8
9
10
11
12
// connect to database
	if($poll_usePersistentConnects == 0)
		$poll_mssql_ID = mssql_connect($poll_mssql_host, $poll_mssql_user, $poll_mssql_pwd);
	else
		$poll_mssql_ID = mssql_pconnect($poll_mssql_host, $poll_mssql_user, $poll_mssql_pwd);

	// select all descriptions
	$poll_result = mssql_query($poll_dbName, 'SELECT * FROM $poll_descTableName'); 
	if(!$poll_result)
	{
		echo mssql_errno(). ": ".mssql_error(). "<br>";
		return;

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Scirocco81« (13.12.2005, 12:45)


dfex

Junior Schreiberling

  • »dfex« ist männlich

Beiträge: 248

Registrierungsdatum: 11.12.2001

5

13.12.2005, 15:26

Wir hatten das übrigens schonmal:
http://forum.finf.uni-hannover.de/thread…1&hilight=mssql

Mir ist das Problem auch dunkel bekannt. Ich glaube, das hatte etwas mit dem Betriebsystem auf dem Webserver zu tun (auf dem das Script ausgeführt wird). Bei MS Windows gabs da einen Sonderfall zu beachten.
Bin mir aber nicht mehr sicher und find auf die Schnelle auch nix ..

6

13.12.2005, 18:51

mixed mssql_query ( string Anfrage [, resource Verbindungs-Kennung [, int batch_size]] )

Die Parameter sollen's sein, und auch in der Reihenfolge :)

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »maffe« (13.12.2005, 18:53)